The manual button on the switch does not work properly, what do I do?

If the manual button on your Avi-on compatible device does not create predictable on/off behavior, there are a couple of possible causes:

1) A power surge or brownout may have frozen the device.   

  • To fix this problem, power cycle the the device. "Power cycle" means turning the device off, then on, FROM THE POWER SOURCE.  
  • If your device is a plug-in switch, then you just unplug it for 15 seconds, then plug it back in.
  • If your device is an in-wall switch, you can do this by turning on and off the circuit breaker powering the device.

2)  If that does not resolve the issue, then the device may have been damaged. Damage can happen for several reasons:

  • The device was struck
  • Doused with water
  • Experienced a power surge that damaged the circuit
  • You have connected a load larger than the rated power of the device, particularly heaters or large pumps/motors.

3)  You can also try moving the switch to a new location to see if it works there.

  • If the device works in the new location, then your power source or load is causing the problem. You will need to have your electrical line repaired, or it is possible that the load you are controlling is introducing harmful currents on the line.  This can happen with pool pumps or other motors, particularly old units.

If the device does not work correctly after the power cycle or moving the switch, please contact the manufacturer, Jasco Products, at support@jascoproducts.com. Depending on the circumstances, Jasco may warranty the device.

Here is some additional information about connecting to your Avi-on device.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk